[svn] / branches / release-1_1-branch / xvidcore / debian / rules Repository:
ViewVC logotype

Annotation of /branches/release-1_1-branch/xvidcore/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1715 - (view) (download)

1 : Isibaar 1697 #!/usr/bin/make -f
2 :     # Sample debian/rules that uses debhelper.
3 :     # GNU copyright 1997 to 1999 by Joey Hess.
4 :    
5 :     # This is the debhelper compatibility version to use.
6 :     export DH_COMPAT=4
7 :    
8 :     # Uncomment this to turn on verbose mode.
9 :     #export DH_VERBOSE=1
10 :    
11 :     # These are used for cross-compiling and for saving the configure script
12 :     # from having to guess our platform (since we know it already)
13 :     DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
14 :     DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
15 :    
16 :     # shared library versions, option 1
17 :     version=`ls $(CURDIR)/build/generic/=build/lib*.so.* | \
18 :     awk '{if (match($$0,/[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
19 :     major=`ls $(CURDIR)/build/generic/=build/lib*.so.* | \
20 :     awk '{if (match($$0,/[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}' | \
21 :     cut -d '.' -f 1`
22 :    
23 :     configure: configure-stamp
24 :     configure-stamp:
25 :     dh_testdir
26 :     # Add here commands to configure the package.
27 :     cd $(CURDIR)/build/generic/ && ./configure --host=$(DEB_HOST_GNU_TYPE) --target=$(DEB_BUILD_GNU_TYPE)
28 :    
29 :     touch configure-stamp
30 :    
31 :    
32 :     build: build-stamp
33 :     build-stamp: configure-stamp
34 :     dh_testdir
35 :    
36 :     # Add here commands to compile the package.
37 :     $(MAKE) -C build/generic/ clean all
38 :    
39 :     touch build-stamp
40 :    
41 :     clean:
42 :     dh_testdir
43 :     dh_testroot
44 :     rm -f build-stamp configure-stamp
45 :    
46 :     # Add here commands to clean up after the build process.
47 :     -$(MAKE) -C build/generic/ distclean
48 :    
49 :     dh_clean
50 :    
51 :     install: build
52 :     dh_testdir
53 :     dh_testroot
54 :     dh_clean -k
55 :     dh_installdirs
56 :    
57 :     # Add here commands to install the package into debian/tmp
58 :     $(MAKE) -C build/generic/ install prefix=$(CURDIR)/debian/tmp/usr
59 :    
60 :     # Build architecture-independent files here.
61 :     binary-indep: build install
62 :     # We have nothing to do by default.
63 :    
64 :     # Build architecture-dependent files here.
65 :     binary-arch: build install
66 :     dh_testdir -a
67 :     dh_testroot -a
68 :     dh_installchangelogs -a ChangeLog
69 :     dh_installdocs -a
70 :     dh_installexamples -a
71 :     dh_install -a
72 :     # dh_installmenu
73 :     # dh_installdebconf
74 :     # dh_installlogrotate
75 :     # dh_installemacsen
76 :     # dh_installpam
77 :     # dh_installmime
78 :     # dh_installinit
79 :     # dh_installcron
80 :     # dh_installinfo
81 :     # dh_installman
82 :     dh_link -plibxvidcore$(major) usr/lib/libxvidcore.so.$(version) usr/lib/libxvidcore.so.$(major)
83 :     dh_link -plibxvidcore$(major)-dev usr/lib/libxvidcore.so.$(version) usr/lib/libxvidcore.so
84 :     dh_strip -a
85 :     dh_compress -a
86 :     dh_fixperms -a
87 :     # dh_perl
88 :     # d_python
89 :     dh_makeshlibs -V
90 :     dh_installdeb -a
91 :     dh_shlibdeps -a
92 :     dh_gencontrol -a
93 :     dh_md5sums -a
94 :     dh_builddeb -a
95 :    
96 :     binary: binary-indep binary-arch
97 :     .PHONY: build clean binary-indep binary-arch binary install configure

No admin address has been configured
ViewVC Help
Powered by ViewVC 1.0.4