[svn] / branches / dev-api-4 / xvidcore / examples / Makefile Repository:
ViewVC logotype

View of /branches/dev-api-4/xvidcore/examples/Makefile

Parent Directory Parent Directory | Revision Log Revision Log


Revision 918 - (download) (annotate)
Tue Mar 11 23:39:47 2003 UTC (16 years, 4 months ago) by edgomez
File size: 973 byte(s)
2003-03-11 23:37:06 GMT	Edouard Gomez <ed.gomez@free.fr>	patch-9

    Summary:
      Changed xvid_decraw option handling for -d/-m.
    Revision:
      xvidcore--devapi4--1.0--patch-9

    -d and -m options were boolean so option values were not needed.

    modified files:
     examples/xvid_decraw.c


2003-03-11 23:30:16 GMT	Edouard Gomez <ed.gomez@free.fr>	patch-8

    Summary:
      Fixed frame counting in xvid_encraw.
    Revision:
      xvidcore--devapi4--1.0--patch-8

    We were branching before incrementing  the frame counter when core was
    buffering frames.  This was resulting  in wrong frame  counting during
    the buffering phase.

    modified files:
     examples/xvid_encraw.c


2003-03-11 23:07:01 GMT	Edouard Gomez <ed.gomez@free.fr>	patch-7

    Summary:
      Ported xvid_decraw to new API.
    Revision:
      xvidcore--devapi4--1.0--patch-7

    xvid_decraw  has been  ported to  new  API. It  basically works  fine,
    however i'm not completly staisfied. If I do a step by step run then i
    can see  that second frame  is reported as  a VOL decoding  though the
    first IFrame has been consumed. This makes xvid_decraw does not report
    correctly frames' length.

    Except  that, xvid_decraw  works well  enough  to activate  it in  the
    makefile.

    modified files:
     examples/Makefile examples/xvid_decraw.c
#############################################################################
#
# XviD examples Makefile
#
# $Id: Makefile,v 1.3.2.2 2003-03-11 23:39:47 edgomez Exp $
#
#############################################################################

CC=gcc

HDIR    = -I ../src
CFLAGS  = -Wall -g
LDFLAGS = -lc -lm

SOURCES= xvid_encraw.c xvid_decraw.c
OBJECTS=$(SOURCES:.c=.o)
TESTS=$(SOURCES:.c=)

all: $(TESTS)

xvid_stat: xvid_stat.o ../build/generic/libxvidcore.a
	$(CC) $(LDFLAGS) -o $@ $< ../build/generic/libxvidcore.a

xvid_stat.o: xvid_stat.c
	$(CC) $(CFLAGS) $(HDIR) -c $<

xvid_encraw: xvid_encraw.o ../build/generic/libxvidcore.a
	$(CC) $(LDFLAGS) -o $@ $< ../build/generic/libxvidcore.a

xvid_encraw.o: xvid_encraw.c
	$(CC) $(CFLAGS) $(HDIR) -c $<

xvid_decraw: xvid_decraw.o ../build/generic/libxvidcore.a
	$(CC) $(LDFLAGS) -o $@ $< ../build/generic/libxvidcore.a

xvid_decraw.o: xvid_decraw.c
	$(CC) $(CFLAGS) $(HDIR) -c $<

clean:
	rm -f $(OBJECTS) $(TESTS)

No admin address has been configured
ViewVC Help
Powered by ViewVC 1.0.4